Search found 7 matches

by amarkovitz
Wed Jul 26, 2017 5:01 pm
Forum: runmlwin user forum
Topic: Post-estimation after mi estimate: mimrgns error
Replies: 1
Views: 2527

Re: Post-estimation after mi estimate: mimrgns error

To close out this topic (unless anyone has advice), I believe the following post answers my question about whether mimargins can be used in conjunction with runmlwin. The answer is no. https://www.cmm.bristol.ac.uk/forum/viewtopic.php?f=3&t=1929&sid=d7cfd5152e73b023f200ccd0d489edb4#p4431 It ...
by amarkovitz
Thu Jul 20, 2017 10:16 pm
Forum: runmlwin user forum
Topic: Post-estimation after mi estimate: mimrgns error
Replies: 1
Views: 2527

Post-estimation after mi estimate: mimrgns error

Hello all, I have used the very helpful posts here to run runmlwin after multiple imputation using mi estimate. However, I need to make out-of-sample predictions after this procedure and have found that mimgrns from SSC is one of the few (or only?) possible way to do this despite some caveats to the...
by amarkovitz
Wed Aug 31, 2016 1:57 pm
Forum: Realcom user forum
Topic: Imputation files not found
Replies: 9
Views: 6832

Re: Imputation files not found

Hello Chris, I tried to use a publicly available dataset and I did not receive the error about missing data, but it is having the estimation problem that I initially wrote about: . realcomImputeLoad file impvals.txt not found Perhaps it just isn't a very good example and if so please let me know an ...
by amarkovitz
Thu Aug 25, 2016 9:34 pm
Forum: Realcom user forum
Topic: Imputation files not found
Replies: 9
Views: 6832

Re: Imputation files not found

Hello Chris, Unfortunately, I did try that and received the same error. I've also tried a few different missing values (ex. STATA's default -9.999e+29, 9999, and 99999) and also have tried running the model with different response and auxiliary variables to see if was something wrong with the variab...
by amarkovitz
Tue Aug 23, 2016 6:48 pm
Forum: Realcom user forum
Topic: Imputation files not found
Replies: 9
Views: 6832

Re: Imputation files not found

Hello Chris, Thank you for that information, that will be very helpful. In an effort to try to figure out what might be going wrong, I tried to simplify the problem. I ran MI again with just two variables, BMI at age 18 which is missing for about 44% of people and current BMI which I made sure was n...
by amarkovitz
Tue Aug 23, 2016 1:56 pm
Forum: Realcom user forum
Topic: Imputation files not found
Replies: 9
Views: 6832

Re: Imputation files not found

Hello Chris, Thank you for the fast reply. It does seem like there might have been estimation problems, although I did not see anything in the log to indicate this. When I click "view results" I do get error messages (attached). I did monitor one of the MCMC trajectories while it was runni...
by amarkovitz
Mon Aug 22, 2016 10:33 pm
Forum: Realcom user forum
Topic: Imputation files not found
Replies: 9
Views: 6832

Imputation files not found

Hello, I ran what appeared to be a successful imputation procedure, but when I type realcomImputeLoad in stata, I am getting the following error: file imputeiter100. not found If it's helpful to diagnose this error, here is my model in stata: realcomImpute bmi bmixsplinea1 bmixsplinea2 bmixsplinea3 ...