Search found 63 matches

by adeldaoud
Sat Oct 17, 2015 3:29 am
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

NB: although this is only a 10 iteration model, it uses the IGLS starting values and the numbers are quite similar to the MCMC model without starting values. (I am running this model with 15 000 iterations currently. That will take 9h +…) So, even if I run the model for 15 000 iterations, the diffe...
by adeldaoud
Fri Oct 16, 2015 10:14 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

When you supply starting values what should happen is that before the MCMC run is started the model is run for two iterations with IGLS, which should set up the constraints and other aspects of the model correctly. In your case the constraints column is being left empty (you'd to have run the model...
by adeldaoud
Fri Oct 16, 2015 10:09 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

1) I am re-running the model in the development version currently. I will come back as soon as I have some new results. The model is now being run without errors on the large data set, which is great. However, both the random and the fixed part of the model are showing some abnormally high discrepa...
by adeldaoud
Fri Oct 16, 2015 6:53 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

Thanks for looking at this. The mcmcchains column should only be 40 rows as well (as it's the stacked chains of 10 iterations for 4 parameters). My guess would be that this difference is due to the refresh MCMC option, which is set to 50 iterations by default. This is only used when debugmode is tu...
by adeldaoud
Fri Oct 16, 2015 4:15 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

Thanks Chris. I will check the refresh option asap for the second issue (the one where runmlwin manages to estimate in non-debugmode but not in debugmode). Do you have any input on the first issue, which is the more pressing one? I would be happy to share the data with you if that would make trouble...
by adeldaoud
Thu Oct 15, 2015 11:23 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

This looks like a different error to that you reported before. Could you check that the 'mcmchains' column contains the same number of rows as the 'parnum' and 'itnum' columns? I assume that you are referring to the second. Mcmchains has 440 columns whereas parnum and itnum has only 40 each. Could ...
by adeldaoud
Thu Oct 15, 2015 7:32 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

I re-ran with the data which is supposed to work in debugmode out of curiosity. It seems to fail in debugmode but not in non-debugmode. This is the model output in non-debugmode: Dbar D(thetabar) pD DIC 1289.819 1236.107 53.713 1343.532 ---------------------------------------------------------------...
by adeldaoud
Thu Oct 15, 2015 6:06 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

Re: MCMC is not taking the same starting values but for different datasets

Chris, Thanks for the support. Here come some screenshots: 1. Some curious thing here. Why is the method set to IGLS when I requested a MCMC model? Also, the model outputs “convergence not achieved” before I clicked “Resume Macro”: this text was there when I opened up the Output window. Skärmklipp 2...
by adeldaoud
Wed Oct 14, 2015 4:07 pm
Forum: R2MLwiN user forum
Topic: MCMC is not taking the same starting values but for different datasets
Replies: 14
Views: 3760

MCMC is not taking the same starting values but for different datasets

** I started a new thread instead ** I am following up on this thread, but the question is merely related. I am using starting values and passing both FP.b and RP.b to the model as you suggested. R2mlwing manages to run this model if I use a small random sample of the original data (~ 1000 cases), b...
by adeldaoud
Mon Oct 12, 2015 11:04 pm
Forum: R2MLwiN user forum
Topic: Specifying starting values behaves strangely
Replies: 3
Views: 4623

Re: Specifying starting values behaves strangely

Chris, I am following up on this thread, but the question is merely related. I am using starting values and passing both FP.b and RP.b to the model as you suggested. R2mlwing manages to run this model if I use a small random sample of the original data (~ 1000 cases), but not when I want to estimate...