Page 1 of 1

Error using save

Posted: Fri May 29, 2015 12:03 am
by withus92

I am new to REALCOM-Impute.
I followed the website (REALCOM impute and Stata) using the example data.
After clicking "Start MCMC run", I got error messages:

Error using save
Unable to write file storedata: permission denied
Error in mcmcdriver <line 1192>.....

It is my personal computer. I removed password protection on Windows 8 and tried to save here and there, including the folder which STATA saves its data as default. Still got the same error message.

My computer environment is Windows 8, 64 bit version, but I downloaded the R2012b Windows 32-bit version, as the website ( ... #downloads) guided.

Would you please help me out?

Re: Error using save

Posted: Fri May 29, 2015 10:38 am
by ChrisCharlton
When Realcom-Impute runs it attempts to save the current model state into its working directory, which by default is set to the installation location. Normal users will not have write access to this location and will therefore get the message that you are seeing. To work around this you either have to run the Realcom-Impute executable as a user who can write to that directory (e.g. an administrator) or create a new shortcut that has a different working directory set. I believe that this save actually occurs after the imputed data is created, so it's also possible that you can just ignore the error and use the files that have been created (check that the file dates correspond to when you ran the model).