One variable not imputed

Welcome to the forum for REALCOM users. Feel free to post your question about REALCOM here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Go REALCOM (Developing multilevel models for REAListically COMplex social science data) >> http://www.bristol.ac.uk/cmm/software/realcom/
Post Reply
Jamoo
Posts: 36
Joined: Wed Oct 05, 2011 2:33 pm

One variable not imputed

Post by Jamoo » Mon Jun 08, 2015 7:10 am

Hi

I've just run my realcom model but having successfully loaded it into Stata, one variable (logbmi) was not imputed (i.e. when I type 'mi xeq: summarise varx', no imputed values are included).

Not sure where to start - it was definitely listed in my realcom model as a response when I just checked again.

Any ideas about how to troubleshoot this would be welcome.

realcomImpute code below
realcomImpute logbmi zbmi height wc hrate sqrtsds sqrtser sqrtcb qol pcs mcs ph sca sb sqrtparentbmi /*
*/ attendance m.ethnic m.origin m.language o.income m.education m.single m.insurance o.numinhh o.numcinhh /*
*/ nperprog mean_age age1 sex using nototsc.dat, numresponses(25) /*
*/ cons(cons) level2id(ParticipantID) replace
Many thanks

Jamie

ChrisCharlton
Posts: 1094
Joined: Mon Oct 19, 2009 10:34 am

Re: One variable not imputed

Post by ChrisCharlton » Mon Jun 08, 2015 9:32 am

I would suggest looking at the impvals.txt file that was saved from Realcom-Impute. If the missing variable isn't referenced there then it's probably a Realcom problem, otherwise it's likely to be something wrong with the -realcomImputeLoad- command.

Jamoo
Posts: 36
Joined: Wed Oct 05, 2011 2:33 pm

Re: One variable not imputed

Post by Jamoo » Wed Jun 10, 2015 7:21 am

Thanks Chris

I re-ran the Realcom model and for some reason I couldn't replicate the error. Which is good in the end I suppose, but a bit confusing as I didn't change any of the settings.

Post Reply