Errors in REALCOM-IMPUTE -- NaN, Empty Matrix

Welcome to the forum for REALCOM users. Feel free to post your question about REALCOM here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Go REALCOM (Developing multilevel models for REAListically COMplex social science data) >>
Post Reply
Posts: 1
Joined: Fri Mar 15, 2013 8:01 pm

Errors in REALCOM-IMPUTE -- NaN, Empty Matrix

Post by uthResearcher »

I have been trying to use REALCOM-IMPUTE for the first time, and I can't get it to run the model. I've installed two different MATLAB runtime environments:

1. When I install the one listed here ... #downloads, the program doesn't even run due to a missing mclmcrrt710.dll file.
2. Somewhere else, I was told to request a link to the MATLAB runtime for REALCOM, which I did. The link didn't work (can't post it here, by their request), but looking at the url, it seemed to iterate by ones so I changed from a '2' at the end to a '3', and it downloaded a file called matlab-realcom so I figured that must be right (now I'm not so sure). Anyway, the program ran so I continued on.

I'm a SAS user, and I was able to create a file that the program reads correctly. It recognizes the variables (1 continuous response, 1 continuous explanatory for my test run), the number of observations and the number of level 2 units, and the equations are correct. However, when I click "Start MCMC run," nothing happens. So I switched over to the command prompt for information, and I keep getting the same error(s):
REALCOM-IMPUTE_error.jpg (60.08 KiB) Viewed 3674 times
It seems to be failing to create the BETASTART_2 matrix correctly, which results in a Not a Number (NaN) for the SIGMASTART matrix. I've tried many models, with several response variables, and checked off the list of troubleshooting tips in Goldstein (2011) REALCOM-IMPUTE: Multiple imputation using MLwin. I feel like I've tried everything and I'm not sure what to do next. Any help would be appreciated, and thanks in advance.

EDIT: words.
EDIT 2: I heard back from the person who sent me the link to the MATLAB installer, and I did use the correct one.
Last edited by uthResearcher on Mon Mar 18, 2013 1:30 pm, edited 1 time in total.
Posts: 1252
Joined: Mon Oct 19, 2009 10:34 am

Re: Errors in REALCOM-IMPUTE -- NaN, Empty Matrix

Post by ChrisCharlton »

Would it be possible for you to send the files that you are having problems with to Professor Goldstein (contact details here: and he will try to determine what the problem is?
Post Reply