Error using save

Welcome to the forum for REALCOM users. Feel free to post your question about REALCOM here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Go REALCOM (Developing multilevel models for REAListically COMplex social science data) >>
Post Reply
Posts: 4
Joined: Thu May 28, 2015 11:42 pm

Error using save

Post by withus92 »


I am new to REALCOM-Impute.
I followed the website (REALCOM impute and Stata) using the example data.
After clicking "Start MCMC run", I got error messages:

Error using save
Unable to write file storedata: permission denied
Error in mcmcdriver <line 1192>.....

It is my personal computer. I removed password protection on Windows 8 and tried to save here and there, including the folder which STATA saves its data as default. Still got the same error message.

My computer environment is Windows 8, 64 bit version, but I downloaded the R2012b Windows 32-bit version, as the website ( ... #downloads) guided.

Would you please help me out?
Posts: 1265
Joined: Mon Oct 19, 2009 10:34 am

Re: Error using save

Post by ChrisCharlton »

When Realcom-Impute runs it attempts to save the current model state into its working directory, which by default is set to the installation location. Normal users will not have write access to this location and will therefore get the message that you are seeing. To work around this you either have to run the Realcom-Impute executable as a user who can write to that directory (e.g. an administrator) or create a new shortcut that has a different working directory set. I believe that this save actually occurs after the imputed data is created, so it's also possible that you can just ignore the error and use the files that have been created (check that the file dates correspond to when you ran the model).
Post Reply