2-level multilevel model issues

Welcome to the forum for MLwiN users. Feel free to post your question about MLwiN software here. The Centre for Multilevel Modelling take no responsibility for the accuracy of these posts, we are unable to monitor them closely. Do go ahead and post your question and thank you in advance if you find the time to post any answers!

Remember to check out our extensive software FAQs which may answer your question: http://www.bristol.ac.uk/cmm/software/s ... port-faqs/
Post Reply
vortexxx
Posts: 3
Joined: Thu Aug 01, 2019 2:05 pm

2-level multilevel model issues

Post by vortexxx » Thu Aug 01, 2019 2:48 pm

I am a beginner with MLwin and I am using version 3.04.

When I fit a 2-level model, it says "explanatory variables are different lengths (offset 2)". When I looked it up online, I learned that the n of all my variables should be the same. Then I saw that the issue stemmed from a new variable generated by the system. This variable is called "cons", with the value of "1" for only one participant. Hence the n of cons is 1.

I then tried to start from the beginning and attempted the practice on LEMMA. I started from the chapter 5.1 Comparing groups using multilevel modelling. Using the data for MLwin practice 5.1, I got the same issues:
question.png
question.png (17.17 KiB) Viewed 385 times
I received the same error message and saw that a cons with n = 1 was created.
Also, seems like not all cases were in use (1 of 33988 cases in use, and for the level 2 variable, schooolid, only 1 of 508 was in use.

I think I am missing something very basic. Can anyone kindly offer any advice?

Thank you!

Post Reply